Hi, I hope I can get some help and advice from some smart owners. This is my story. I purchased a 2008 Passion on Dec 12 2009. It has 3,450 miles on it.One owner. I test drove it..loved it..bought it. When I went to pick it up at the dealer in Springfield Mathey said it didn't start. They had had the car since July and have never had a problem. They said that after I drove it the manager was putting it away and saw that the "wrench light" was lit on the dash. They had their mechanic reset the "oil change " thingie...for lack of the correct termon my part. They said that he read the manual and did what the instructions said. Immediately after him doing it the car wouldn't start. They informed me that the car was sent on a flatbead to the SmartCar Dealer in Hartford, Conn to fix the problem. I have been in contact with the dealer where I purchased the car every day and he is keeping me ipdated about the progress. They can't seem to pinpoint the problem. They replaced the entire computer/smart system. It worked for a day then didn't start again. They say that it had the 02 upgrade done on the car. So I still don't have my car but I am starting to be so concerned about owning one as I am afraid of this happening often. My nearest Smart Dealer is 35 minutes away in Warwick Rhode Island. If anyone has had similar problems I would appreciate your help. My picture posted is a model that I keep on my table. Thanks, Doreen

Views: 205

Reply to This

Replies to This Discussion

Sounds like it's still under warranty, so let them figure it out. Has happened to some other folks for a variety of reasons - bad clutch disc (this car is too new for that I think) and a faulty brake light switch (could be) being two. BTW, I wish my nearest dealer was only 35 minutes away. :D

Reply to Discussion

RSS

find a

smart center

go

Photos

Loading…
  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2014   Mercedes-Benz USA, LLC.

Badges  |  Report an Issue  |  Terms of Service