Is anyone having any issues?
I've had my Passion Conmvertible for a little over a month and allthough i like it alot have a few issues and was wondering if anyone else was experienceing any:
1. Electrical issue, the headlights intermitantly "pop" and hte radio goes off and resets - this is totally random.
2. Electrical Issue, Headlights (Highbeams) flash by htemselves when on (so i dont turn them on).
3. One time only - but the transmission (paddle shift version) made a grinding noise when putting it into drive.
4. With the top open and the car turned off, the alarm sets itself off. the only way to stop it from repeating is to close the top.

Tags: beams, cabriolet, electrical, high, issues, passion, radio

Views: 20

Reply to This

Replies to This Discussion

Just to let you know, we have not seen any of these issues in our Passion. Not one thing wrong with it. I hope you are working closely with your dealer.
I am actually about to call them, ive been putting it off. Ill keep yu posted on thier respnse.
Hi Andrew,

I just got my Passion a week ago, and the only issue so far is that the alarm has just decided to not set when I push the button on the key. I'm hoping someone else has had this problem.

Tom
Tom, I'm assuming you've replaced the battery in the keychain? First try cleaning the contacts with a pencil eraser (make sure no residue is left behind) and then reinsert the battery again. If that doesn't fix it then try a new battery.
You need to talk with the Dealer.
If the alarm does not go off when you lock the car- check to make sure everything is closed. It's usually the back that did not close properly. I learned from experience. Also with the convertible- when you store the window pieces in the back, it says "push here" Do that.
My only problem has been the low tire pressure light. I've set the tires to the pressures suggested inside the door jam and the light comes on every morning when the tires are cold.

Last night I had a strange noise from the front of the car. I put the brakes on to make a turn onto my street and it sounded like the fan was hitting something. I looked under the "hood" this morning and the fan is covered. I was downshifting at the same moment so I'm hoping it wasn't the trannie!

Reply to Discussion

RSS

find a

smart center

go

Photos

Loading…
  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2014   Mercedes-Benz USA, LLC.

Badges  |  Report an Issue  |  Terms of Service