On Monday I hit a pothole in the dark, got ESP light and then no acceleration. Stopped car and restarted, drove ok then got warning light again but car continued to drive fine for 5 miles. Got to the stop light and then it would not accelerate. Turned it off and on again a couple of times and then it seemed fine. I just went out again and drove it around for a couple of blocks with no problems. The next day got the ESP light again several times. On Wednesday I got the ESP light and Check Engine light and no acceleration. I turned the car off and tried to restart with no results. Tried several times then it finally started but the lights stayed on. I had to have it towed to the dealer 50 miles away. They ordered a speed control unit on Thursday. On Friday they called and said they noticed that I had installed a Area451 cruise control. They said that if this caused the problem it would not be covered under the warranty. Today (Monday) they called and said that they had disconnected the CC and was going to install a new computer because they were getting some weird codes. Tonight they called and said that everything was fixed. They are saying that the cruise control probably caused the problem by shorting out some things (but they can't prove it). The cruise control was not reconnected after they fixed it. They are charging me $860 and said that it would not be covered under warranty. I will pick it up on Thursday but I will probably not hook the CC back up till I can somehow verify that it is good. I have only good things to say about the CC! Before you take your car in for any repairs, remove the Cruise Control!

Tags: cruise

Views: 50

Reply to This

Replies to This Discussion

I have hit (significant) potholes twice - each time they caused the ESP light to come on. The first time, smart replaced something (not sure what) but they indicated that it was a known problem. The second time, it was because the pothole damaged the wheel...
My ESP came on a few weeks ago without hitting any rough bump. Took it to the dealer and they did a diagnostic and told me that it pointed to the CC that I have installed. I have the MDC unit. They didn't do anything on it but they said they do have a few other problems with other Smart with the CC installed. I am still waiting for a reply from SmartMadness.

David Roller said:
I got my cruise control back. Steven from SmartieParts said that it checked out fine on the bench and in the car. They had no problems with it at all.
Moral of the story is: Go to Advance Auto Parts to get your Codes read for Free before taking it to the SteelerShip... They also let you clear the Codes too, IF You Push The Button...<:-))
Mr. Wong,

Give us (SM) a call at 562-981-6800 and we will do our best to assist you. It sounds like you have had a loose connection. Call us and we will go over everything with you and make sure you are taken care of.

Thank you.

William Wong said:
My ESP came on a few weeks ago without hitting any rough bump. Took it to the dealer and they did a diagnostic and told me that it pointed to the CC that I have installed. I have the MDC unit. They didn't do anything on it but they said they do have a few other problems with other Smart with the CC installed. I am still waiting for a reply from SmartMadness.

David Roller said:
I got my cruise control back. Steven from SmartieParts said that it checked out fine on the bench and in the car. They had no problems with it at all.
This seems to be exactly what happened to my Smart today, Steve installed a Area451 cruise last summer, ESP light and check engine light came on and the engine starts but will not go in gear. Starting to wonder if it isn't the cruis control! I am calling Smart in the AM to have it towed to the shop.

Reply to Discussion

RSS

find a

smart center

go

Photos

Loading…
  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2014   Mercedes-Benz USA, LLC.

Badges  |  Report an Issue  |  Terms of Service