hello fellow smart owners!

has anybody out there had this problem?

i turned on my car last night and instead of stating how many miles i'd driven (approx 8400) it said "-1" and had a wrench flashing. i'll attach the video below. it's done this everytime i've turned the car on since then (5 times) but this afternoon it progressed to "-2". it only flashes the wrench and the negative number for about 20-30 seconds and then switches back to my normal mileage. i have an appt now to take it in friday, but was curious if anybody else has already gone through this?

while i'm at it, has anybody else had to get the back fixed because it wasn't water tight and leaked into the car? i think i need to get an extended warranty because this car seems to have all sorts of problems... hoping i can get one before my 1 year anniversary on april 27th!

thanks to all for any input :-)

Views: 3484

Attachments:

Reply to This

Replies to This Discussion

Seems as if your service indicator has activated.
As Mark B wrote, your 1 year service indicator just came on. Each day, until turned off by your mechanic, the number will decrement by 1... My count-down clock started when the car was prepped off of the ship, not the day I tool delivery.
on the 451 for 08, I hear that the only way to reset the 'service' indicator is to get the dealer to do it.
No, the steps are the same as the 450 -

Switch on the ignition to position 1.
Select maintenance indicator within 4 sec by double tapping the instrument cluster button,
keep it held down on the second press.
Switch of the ignition to position 0 (off) within 10 sec.
Switch ignition on.
Keep the instrument cluster button held down for another 10sec.
In that time, the spanner symbol on the LCD will flash and eventually reset.

It's tricky because the timing has to be just right - it took me about 4 tries. I've heard it doesn't work on the 09, but they said the same thing about the 08, so I'd certainly give it a try.
Hi Joy,

I had a problem with the back not being water tight they replaced the whole window unit and I haven't had a problem since. Some back window units came out defective, the pressurised part where the rear window wiper is located did not seal properly and that is where the leaking occurs (right corner). So far so good for me, with the new unit.
The regular scheduled service interval (including oil change) is every 10,000 miles. (Oil change 10,000 miles or 1 year, whichever comes first.)

Once you've gone past that interval, it will show the wrench and show how many miles you have gone past that interval. If two wrenches are flashing, it's a major service interval. Check your service booklet in your documents package. It will detail for you what is performed.

Although the oil is a fully synthetic Mobil1 5W30, you should not go any longer without changing your oil for the long-term health of your engine. Of course this is the case with ANY engine, not just the smartie.

The dealer will reset your dash when they do the service. Not sure about the secret handshake listed above.

What's nice is that when you take it in for your oil change, you will get the tranny program update.

Happy smarting!
I've tried this several time with no success. I had my one year service, after only 3000 miles, done at my local mechanic. Smartcenter Cary wants to charge me to reset the service indicator light. If anyone knows how to reset it without the dealer I'd love to know how.

sheureka said:
No, the steps are the same as the 450 -

Switch on the ignition to position 1.
Select maintenance indicator within 4 sec by double tapping the instrument cluster button,
keep it held down on the second press.
Switch of the ignition to position 0 (off) within 10 sec.
Switch ignition on.
Keep the instrument cluster button held down for another 10sec.
In that time, the spanner symbol on the LCD will flash and eventually reset.

It's tricky because the timing has to be just right - it took me about 4 tries. I've heard it doesn't work on the 09, but they said the same thing about the 08, so I'd certainly give it a try.
Did you try it, did it work?
Question which side is the instrument cluster button, is it the one that resets the trip milage?

Reply to Discussion

RSS

find a

smart center

go

Photos

Loading…
  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2014   Mercedes-Benz USA, LLC.

Badges  |  Report an Issue  |  Terms of Service