I get an intermittent popping sound when the defroster is on. It happens mostly in 2nd gear. And when I shift from 1st to second, the engine backfires. I called to ask about the the popping sound and the service writer said it was "normal."  I let it go at that but I have a hard time believing this is "normal." I don't buy it. No car I have ever driven has had this happen. Service guy asked what gas I was using I told him the recommended kind----91 octane.

Does anyone out there have the same problem?

 

Views: 71

Reply to This

Replies to This Discussion

I don't recall ever earing a popping sound

Never heard a popping sound with or without the defroster on much less the engine backfiring. This needs to be looked at by someone who will listen to you. Maybe call a dealership in another city and get their opinion?

Good luck and be careful out there,

Pops and Carlito

Thanks guys.
Where can you buy 91 octane gas?  We have to buy 93 octane in NC.  I would try a different brand of gas first or a different station.  If its still doing it bring it back to the dealer.
Some stations have it. I work in Anchorage Ak and the Shell stations have 91 octane (@ $4.25 per gallon...)
In California the highest octane available is 91 and it costs in the low- to mid- $4 range. I've seen it at $4.69 even.

Reply to Discussion

RSS

find a

smart center

go

Photos

Loading…
  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2014   Mercedes-Benz USA, LLC.

Badges  |  Report an Issue  |  Terms of Service