Just as a FYI for anyone that has the Kenwood system with the ipod connector. I had problems where my ipod(s) stopped working with the system. They would play but the system didn't recognize the Ipod and you couldn't use the Kenwood controls to pause, etc. I went to the dealer. They couldn't figure it out. They hooked me up with the vendor who installed it and it couldn't figure it out and suggested I called Kenwood. They ran me through this process up upgrading the Kenwood software to no avail.

I figured it out when I tried to connect the Ipods to my computer to download something; it didn't recognize them!! I prompt rebooted the Ipods and then took them to my smart and the Kenwood has been recognizing them every since. I called back Kenwood customer service & vendor to tell them the fix and told them I was surprised they never suggested it in the first place!!!

Rebooting typically solves 99% of all computer problems; how come I didn't remember that!

Tags: Kenwood, ipod, rebooting

Views: 48

Reply to This

Replies to This Discussion

great info ... power off/on did the trick .... do you mind if I ask what Kenwood do you have installed? are you using a rearview cam? Thanks .... daniel
Hi,

Kenwood DNX5120 (with nav system, dvd player, etc. but no rear cam). It was suggested I needed the software update and boy was that a pain! That didn't fix that problem either. Like I said. I was surprized no one else suggested rebooting the Ipods and it just didn't dawn on me until I connected them to my computer and tried to download something to them.

http://www.kenwood.com/cs/ce/mm/firmware/2008/eng.html
Here is the link for the software update.

Reply to Discussion

RSS

find a

smart center

go

Photos

Loading…
  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2014   Mercedes-Benz USA, LLC.

Badges  |  Report an Issue  |  Terms of Service