Odd Electrical Problem: Window Washer, Seat Warmers, Radio, Rear Defroster. Help please

I have a 4 month old 2009 Cabrio with 4000 miles.

We are having our first snow storm of the season, 8 inches of snow and temparture from -4 f.

After driving the car without a problem in the morning over bumpy packed snow, I was drving it at noon time and after I stopped and restarted the engine and I had 4 problems:

1.) The window washer wasn't working.

2.) The heated seat button wouldn't turn on, however if you press the buttons the red indicator would stay on as long as you pressed the button.

3.) And most strangely. The radio doesn't turn off when the key is turned off. It must be turned off manually.

4.) The rear defroster is not working, however if you press the buttons the red indicator would stay on as long as you pressed the button.

No fuses are burned out. Any ideas?

I have an appointment with the dealer next week. Thanks, Alan

Views: 95

Reply to This

Replies to This Discussion

The problem is there are two kinds of washer fluid summer and winter the washer tank on the smart is so large that the fluid last very long ie fill in the summer and lasts till winter when it will freeze . When frozen the firts time you hit the washers the pump can not move and the fuse blows . Best thing to do is change your washer fluid.
Better yet, put in the "winter" fluid and leave it; no need to switch fluids.

smarttechlou said:
The problem is there are two kinds of washer fluid summer and winter the washer tank on the smart is so large that the fluid last very long ie fill in the summer and lasts till winter when it will freeze . When frozen the firts time you hit the washers the pump can not move and the fuse blows . Best thing to do is change your washer fluid.

Glad to see this discussion on here...even if it is over 2 years later!  I just had this happen today.  Got in the car & the seat heaters wouldn't turn on, then neither would the AC, rear defroster, or air circulation switch for max AC.  I had tried to see if I could get a few final drops of windshield washer out to clean the windshield.  Don't know if that worked or not.  Could've been what blew the fuse.  So I'm gonna go get a fuse for #20, then refill my windshield washer & see if this fixes it.  Hope so!

Reply to Discussion

RSS

find a

smart center

go

Photos

Loading…
  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2014   Mercedes-Benz USA, LLC.

Badges  |  Report an Issue  |  Terms of Service